Opened 11 years ago

Closed 11 years ago

#541 closed defect (fixed)

Failed to install BIndings

Reported by: thomaszoeller Owned by: Olly Betts
Priority: normal Milestone: 1.2.5
Component: Xapian-bindings Version: 1.2.4
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Operating System: Mac OS X

Description

INstalling core without problems. INstalling BIndings: configure without problems, after Make: IOError: $MACOSX_DEPLOYMENT_TARGET mismatch: now "10.3" but "10.6" during configure

Thank you!

OSX 10.6.6

Change History (2)

comment:1 by Olly Betts, 11 years ago

I think this is Python complaining.

If you start from a clean source tree and set MACOSX_DEPLOYMENT_TARGET to the value Python wants before configure like so, does it work?

export MACOSX_DEPLOYMENT_TARGET=10.6
./configure
make

comment:2 by Olly Betts, 11 years ago

Milestone: 1.2.x1.2.5
Resolution: fixed
Status: newclosed

A couple of OS X users couldn't reproduce your issue, but I've committed a change (r15399) so we no longer set MACOSX_DEPLOYMENT_TARGET on modern OS X. So it'll now default to the current OS X version, which means it'll be compatible with what Python expects for you.

Note: See TracTickets for help on using tickets.