Opened 9 years ago

Closed 9 years ago

#501 closed defect (fixed)

Doxygen fails to build on Mac OS X "snow leopard"

Reported by: richard Owned by: richard
Priority: normal Milestone: 1.2.4
Component: Build system Version: SVN trunk
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Operating System: Mac OS X

Description (last modified by olly)

On Mac OS X "snow leopard", when running bootstrap, doxygen fails to build with an error "This version of Mac OS X is unsupported" (as noted in comment:3:ticket:396). Upgrading the version of doxygen used by bootstrap to 1.7.1 fixes the problem. We should probably upgrade therefore, though we need to check if any config updates are needed for this, and check that the generated output is still good.

Change History (5)

comment:1 Changed 9 years ago by olly

  • Description modified (diff)

Or we could add a line to bootstrap to fix this with a sed hammer on the doxygen source so we don't have to play this game for every new Mac OS X release. This check is in a header taken from Qt, and in the context of doxygen the results of this test aren't ever used (try rgrep MAC_OS_X_VERSION doxygen-1.5.9 - the only uses are in ./qtools/qglobal.h and the last one is the check that fails).

comment:2 Changed 9 years ago by olly

  • Milestone changed from 1.2.3 to 1.2.4

I want to release 1.2.3, so bumping. This is only relevant for building from SVN, so targetting it at a particular release doesn't really mean much anyway.

comment:3 Changed 9 years ago by olly

Should be fixed by r14922 (but untested as I don't have access to Mac OS X).

Can you test and close this ticket if it is fixed?

To force bootstrap to rebuild doxygen, you just need to do:

rm INST/doxygen.stamp

comment:4 Changed 9 years ago by olly

  • Owner changed from olly to richard

Reassigning to Richard, since he can actually test this!

comment:5 Changed 9 years ago by olly

  • Resolution set to fixed
  • Status changed from new to closed

Richard confirmed on IRC that doxygen now builds ok.

Note: See TracTickets for help on using tickets.