Opened 12 years ago

Closed 12 years ago

#443 closed defect (fixed)

closedb5() test fails on Flint database

Reported by: Charlie Hull Owned by: Olly Betts
Priority: normal Milestone: 1.1.4
Component: Test Suite Version: SVN trunk
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Operating System: Microsoft Windows

Description

Fails as follows on Windows:

apitest -v -b flint closedb5

Running tests with backend "flint"...
Running test: closedb5....flint\dbw\postlist.DB - The process cannot access the file because it is being used by another process.
.flint\dbw\record.DB - The process cannot access the file because it is being used by another process.
.flint\dbw\termlist.DB - The process cannot access the file because it is being used by another process.
.flint\dbw\value.DB - The process cannot access the file because it is being used by another process.
 DatabaseError: Can't delete file: `.flint/dbw/value.DB': Permission denied
apitest backend flint: 0 tests passed, 1 failed.

Can be fixed by adding "db.close();" at line 188 of api_closedb.cc

Change History (2)

comment:1 by Olly Betts, 12 years ago

Milestone: 1.1.4
Status: newassigned

Should be fixed by r13963. I tweaked the object lifetimes rather than using close().

Leaving open until fix confirmed.

This test is for functionality not present in 1.0.x, so nothing to backport.

comment:2 by Charlie Hull, 12 years ago

Resolution: fixed
Status: assignedclosed

Verified & closed.

Note: See TracTickets for help on using tickets.